ytooyamaのブログ

サーバ構築とか、仕事で発見したこととか、趣味のこととかを書いています。

L3 CatalystでVLANを作りテスト用のネットワークを作る(2)

前回はVLANを作りましたので、今回は既存のインターネットとつながっているネットワークとつなぎ、他のセグメントにいる端末からアクセスできるようにしてみます。

ルーティング有効化

cat3550# configure terminal
cat3550(config)# ip routing

ああ、ちなみに"configure terminal"と打たず、"conf t"でも良いです。今更言うのもなんですが、省略形でもコマンドは通ります。

VLANの切り替え

VLAN10の仮想インタフェースに192.168.10.254/24を割り当てます。

cat3550# configure terminal
cat3550(config)# interface vlan 10
cat3550(config-if)# ip address 192.168.10.254 255.255.255.0

同様に、VLAN20の仮想インタフェースに192.168.20.254/24を割り当てます。

cat3550# configure terminal
cat3550(config)# interface vlan 20
cat3550(config-if)# ip address 192.168.20.254 255.255.255.0

ゲートウェイとつながっているネットワークをvlan1と仮定し、
vlan1にIPアドレスを割り当てます。

cat3550# configure terminal
cat3550(config)# interface vlan 1
cat3550(config-if)# ip address 192.168.1.254 255.255.255.0

ルーティング設定の確認

cat3550#show ip route

インターフェイスにVLANを設定

  • fastethernet 0/41ポート

cat3550# configure terminal
cat3550(config)# interface fastethernet 0/41
cat3550(config-if)# switchport mode access
cat3550(config-if)# switchport access vlan 10
cat3550(config-if)# end

  • fastethernet 0/42ポート

cat3550# configure terminal
cat3550(config)# interface fastethernet 0/42
cat3550(config-if)# switchport mode access
cat3550(config-if)# switchport access vlan 20
cat3550(config-if)# end

設定の保存

cat3550# write

スイッチのデフォルト ルートを設定

cat3550# configure terminal
cat3550(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

トランクポートの指定

VLANを流して他のスイッチやルーターへ流す口を作ります。

cat3550# configure terminal
cat3550(config)# interface fastethernet 0/1
cat3550(config-if)# switchport trunk encapsulation dot1q
cat3550(config-if)# switchport mode trunk
cat3550(config-if)# end

※switchport trunk encapsulation islでも可。この辺りは機種によります。

確認

  • fastethernet 0/41にPC-Aを接続
  • fastethernet 0/42にPC-Bを接続
  • IPアドレスを設定

PC-A(fastethernet 0/41)側

  • address 192.168.10.100
  • mask 255.255.255.0
  • router 192.168.1.254

PC-B(fastethernet 0/42)側

  • address 192.168.20.100
  • mask 255.255.255.0
  • router 192.168.1.254

PC-Aからルーター

ping 192.168.10.254

PC-Bからルーター

ping 192.168.20.254

PC-Aからゲートウェイ

ping 192.168.1.1

PC-Bからゲートウェイ

ping 192.168.1.1

※接続できない場合は、クライアントのファイアウォール
ICMPをブロックしていないか確認すること。

最後に上位ルーターの設定

静的ルーティングの設定を仕込めば良いようです。私が使っているPR-S300NEの場合は次の通りです。

接続確認

別のセグメントから、VLAN 10の範囲にいるサーバーにアクセスしてみます。

$ ifconfig en0 |grep inet[^6]
inet 192.168.1.154 netmask 0xffffff00 broadcast 192.168.1.255
...

  • SSH接続してみる

$ ssh tooyama@192.168.10.100
tooyama@192.168.10.100's password:
Welcome to Ubuntu 14.04.1 LTS (GNU/Linux 3.13.0-32-generic x86_64)

* Documentation: https://help.ubuntu.com/

System information as of Sat Feb 7 17:36:02 JST 2015

System load: 0.0 Processes: 94
Usage of /home: 0.1% of 89.75GB Users logged in: 1
Memory usage: 1% IP address for em1: 192.168.10.100
Swap usage: 0%

Graph this data and manage this system at:
https://landscape.canonical.com/

Last login: Sat Feb 7 17:36:03 2015 from 192.168.1.154

上手くいきました。
終わり。

備忘録

【参考】複数インターフェイスを一括指定するには"range"を使う。

cat3550# configure terminal
cat3550(config)# interface range fastethernet 0/46 - 48
cat3550(config-if-range)# switchport mode access
cat3550(config-if-range)# switchport access vlan 10
cat3550(config-if-range)# end

【参考】端末でのIPアドレス設定

auto em1
iface em1 inet static
address 192.168.10.100
netmask 255.255.0.0
gateway 192.168.1.1
dns-nameservers 192.168.1.6 #Local DNS